L298N driver problem

Rasprava o AVR mikrokontrolerima, AVR projekti i drugo vezano za AVR...

Moderators: stojke369, pedja089, trax, InTheStillOfTheNight

L298N driver problem

Postby golub » 07-04-2020, 06:25

Pozdrav, pokušavam da pokrenem DC motor pomoću L298N i imam čudan problem. Motor radi na 12V i doveo sam 12v kao napajanje za L298H, pošto je napon 12V nisam dirao jumper za 5V. kad na IN1 dovedem +5V, a na IN2 GND na izlazu OUT1 imam +12v a na OUT2 GND i motor se okreće. Problem je kad na IN1 dovedem GND, a IN2 dovedem +5V, OUT1 mi GND a OUT2 mi je +12V, ali motor se ne pokreće. Imam 2 takva modula i oba se isto ponašaju, motor normalno radi kada ga vežem direknto i kada obrnem polaritet promeni smer. Svak i savet je dobrodošao, hvala unapred
golub
 
Posts: 28
Joined: 16-11-2014, 11:58

Re: L298N driver problem


Re: L298N driver problem

Postby bob4 » 07-04-2020, 10:11

Da li si konfigurirao PIN 1 i PIN 6 ?
User avatar
bob4
 
Posts: 2542
Joined: 31-01-2010, 16:12
Location: Kutina

Re: L298N driver problem

Postby golub » 07-04-2020, 12:03

Pa napisao sam već, doveo sam +5v na ENA i ENB, ako na njih mislis pod 1 i 6, ovo je bez arduina. Sa arduinom takođe ide samo jedan smer
golub
 
Posts: 28
Joined: 16-11-2014, 11:58

Re: L298N driver problem

Postby bob4 » 07-04-2020, 14:06

Još jednom polako pročitaj moj post ( a možeš i svoja oba) :wink: ako nije jasno pod konfigurirao; može i :spojio po tehničkim podacima za čip ....
User avatar
bob4
 
Posts: 2542
Joined: 31-01-2010, 16:12
Location: Kutina

Re: L298N driver problem

Postby golub » 07-04-2020, 14:29

Evo crteža, nadam se da je sad jasnije
Attachments
shema.jpg
shema.jpg (27.13 KiB) Viewed 1950 times
golub
 
Posts: 28
Joined: 16-11-2014, 11:58

Re: L298N driver problem

Postby bob4 » 07-04-2020, 19:05

Image

Znači ; kad spojiš crveno motor ide na jednu stranu, a kad spojiš plavo motor se ne vrti ?? da li sam sad shvatio ? :roll:
User avatar
bob4
 
Posts: 2542
Joined: 31-01-2010, 16:12
Location: Kutina

Re: L298N driver problem

Postby golub » 08-04-2020, 06:13

ne umem prostije da objasnim:
- Na ENA sam doveo +5V (crvena žica) i ona je prisutna u oba slučaja

1) slucaj
- Na IN1 sam doveo +5V (zelena žica)
- Na IN2 sam doveo 0V tj GND (ljubičasta žica)

napon između out 1 i out 2 je 12V
motor se okreće u jednom smeru punom brzinom

2) slucaj
- Na IN1 sam doveo 0V tj GND (zelena žica)
- Na IN2 sam doveo +5V (ljubičasta žica)

napon između out 1 i out 2 je -12V
motor se ne okreće
golub
 
Posts: 28
Joined: 16-11-2014, 11:58

Re: L298N driver problem

Postby bob4 » 08-04-2020, 10:54

Ajde umjesto motora stavi otpornik od 10 ohma i mjeri struju....
ps. i nigdje nepiše da se na EN dovodi 5V, već tamo stoji brika ( ako sam u pravu) . Daj poslikaj tvoju pločicu
User avatar
bob4
 
Posts: 2542
Joined: 31-01-2010, 16:12
Location: Kutina

Re: L298N driver problem

Postby golub » 08-04-2020, 11:58

Rešio sam sve je OK, motor i modul su mi bili na metalnom postolju pa kad sam ih odvojio sve radi kako treba
Hvala na pomoći
golub
 
Posts: 28
Joined: 16-11-2014, 11:58

Re: L298N driver problem

Postby bob4 » 08-04-2020, 18:53

:shock: :wink: :wink:
User avatar
bob4
 
Posts: 2542
Joined: 31-01-2010, 16:12
Location: Kutina

Re: Re: L298N driver problem



Return to Mikrokontroleri - AVR

Who is online

Users browsing this forum: No registered users and 2 guests

GOOGLE